We are pleased to report that a fix has been successfully implemented to address this issue, and it is now resolved. Users should no longer encounter slow loading behavior when trying to log in and/or navigate the system.
If you have any questions, or if you run into any continued issues, please contact Support and we would be happy to assist.
Posted Jan 12, 2026 - 13:27 EST
Update
We are continuing to investigate this issue.
Posted Jan 12, 2026 - 12:00 EST
Update
We are continuing to investigate this issue.
Posted Jan 12, 2026 - 11:28 EST
Investigating
We are currently investigating an issue impacting system performance. Users might experience slow loading when trying to log in and/or navigate the system. Our teams are engaged, and we are working toward a solution as quickly as possible.
Posted Jan 12, 2026 - 11:09 EST
This incident affected: Absence Management, Frontline Central, Plan and Service Management, Professional Growth, Recruiting & Hiring Classic, SEI - eStar v3, and Time and Attendance.