10/16 - T&A Performance Issues

Incident Report for Frontline Education

Resolved

After careful monitoring, we are pleased to confirm that system performance within Time & Attendance has fully stabilized and normal functionality has been restored. This incident has been resolved.
Posted Oct 23, 2025 - 17:46 EDT

Monitoring

Our Engineering team implemented a fix designed to address the issue, and our results so far are showing stable performance. Our teams are continuing to monitor the system closely to ensure it remains reliable and fully functional. We will send out additional communication once we have validated that the issue has been fully resolved.
Posted Oct 22, 2025 - 08:50 EDT

Update

We are are continuing to investigate performance issues within Time & Attendance. Users may be encountering slow loading and error messages within the web, mobile app, and on kiosks. We continue to actively work toward a permanent solution.
Posted Oct 21, 2025 - 08:15 EDT

Update

We are continuing to investigate performance issues occurring within Time & Attendance. We appreciate your continued patience as we work toward a resolution as quickly as possible.
Posted Oct 20, 2025 - 16:46 EDT

Investigating

We are seeing new reports of issues within the Time & Attendance applications. User might see error messages or slowness when trying to clock into scheduled position assignments via the mobile app or at a designated kiosk.
Posted Oct 20, 2025 - 08:48 EDT

Monitoring

We have implemented a fix for the performance issues that are occurring within Time & Attendance. System performance has stabilized, and our teams are continuing to monitor the issue to ensure everything remains operational. We will provide a final update once we reach a confirmed resolution.
Posted Oct 17, 2025 - 17:46 EDT

Investigating

We are currently investigating performance issues within Time & Attendance. Users may encounter slow loading when trying to navigate the website and utilize the Kiosks. We are actively working on remediating the issue as quickly as possible.
Posted Oct 17, 2025 - 09:21 EDT

Monitoring

We are pleased to report that this issue is no longer occurring. While system performance has stabilized, we are continuing to closely monitor the issue to ensure everything remains operational. We will provide another update once we reach a confirmed resolution.
Posted Oct 16, 2025 - 10:53 EDT

Investigating

We are currently investigating performance issues within Time & Attendance. Users might encounter lagging/slowness when trying to navigate within Time & Attendance, and users may see issues trying to access Time & Attendance via the mobile app.
Posted Oct 16, 2025 - 09:13 EDT
This incident affected: Time and Attendance.